Python 3.7 requires newer OpenSSL. Fix build on netbsd-7 trunk
authorryoon <ryoon@pkgsrc.org>
Mon, 09 Jul 2018 11:58:58 +0000
branchtrunk
changeset 310272 6552955cc906
parent 310271 6b39538d045f
child 310273 79873cf03347
Python 3.7 requires newer OpenSSL. Fix build on netbsd-7
lang/python37/Makefile
--- a/lang/python37/Makefile	Mon Jul 09 08:23:17 2018 +0000
+++ b/lang/python37/Makefile	Mon Jul 09 11:58:58 2018 +0000
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.1 2018/07/03 03:55:40 adam Exp $
+# $NetBSD: Makefile,v 1.2 2018/07/09 11:58:58 ryoon Exp $
 
 .include "dist.mk"
 
@@ -193,6 +193,7 @@
 .include "../../devel/libuuid/buildlink3.mk"
 .include "../../devel/readline/buildlink3.mk"
 .include "../../devel/zlib/buildlink3.mk"
+BUILDLINK_API_DEPENDS.openssl+=	openssl>=1.0.2
 .include "../../security/openssl/buildlink3.mk"
 .include "../../mk/bdb.buildlink3.mk"
 .include "../../mk/dlopen.buildlink3.mk"